Update NetBackup on Unix/Linux

Few servers who have NetBackup (NBU) clients need to be updated (fra 6.5 in this case).

[root@encore admincmd]# ./bpplclients -allunique -noheader | egrep 'nnit[q,p]iwsdb0[1,2]' | sort > /tmp/nnitpqiws.txt

[root@encore admincmd]# update_clients -ClientList /tmp/nnitpqiws.txt
There are 3 clients to upgrade.

Do you want the bp.conf file on the clients updated
to list this server as the master server? [y,n] (y)

Enter the number of simultaneous updates you wish to take place [1 - 3] (default: 3):

The upgrade will likely take 1 to 2 minutes.
Do you want to upgrade clients now? [y,n] (y)
Please be patient.

Updating client nnitpiwsdb01 -- Linux hardware running RedHat2.6.18
Updating client nnitpiwsdb02 -- Linux hardware running RedHat2.6.18
Updating client nnitqiwsdb01 -- Linux hardware running RedHat2.6.18

The update trace can be found in /tmp/update_clients.10-23-1120.27219.

[root@encore admincmd]# for x in nnitpiwsdb01 nnitpiwsdb02 nnitqiwsdb01; do bpgetconfig -s $x -L -A | awk -F'=' '{if($1~/Client.OS/){os=$2} \
                if($1~/Patch/)   {p=$2} \
                if($1~/Protocol/){v=$2}} \
                END { if(p~/^ *$/){r=v}else{r=p} \
                      printf("%-22s\t%-25s\t%s\n","'$x'",os,r)}'; done
nnitpiwsdb01             Linux 2.6.32-504.30.3.el6.x86_64        7.7.3
nnitpiwsdb02             Linux 2.6.32-504.30.3.el6.x86_64        7.7.3
nnitqiwsdb01             Linux 2.6.32-504.30.3.el6.x86_64        7.7.3

Credit to the one who posted how to get NBU client version on this forum.

No comments:

Post a Comment